TEL: 0086-571-56623320    EMAIL: SALES@SUNLONGBIOTECH.COM

Your Position: Home > system > help > questions > Troubleshooting for elisa kit

View History

                                                                     Troubleshooting

 

    Possible Case

    Solution

 

High Background

Improper washing

Substrate was contaminated

Non-specific binding of antibody

Plate are not be sealing incompletely

Incorrect incubation temperature

Substrate exposed to light prior to use

Contaminated wash buffer

Increasing duration of soaking steps

Replace. Substrate should be clean and avoid crossed contamination by using the sealer

Replace another purified antibody or blocking buffer

Make sure to follow the instruction strictly

Incubate at room temperature

Keep substrate in a dark place

Use a clean buffers and sterile filter

Weak Signal

Improper washing

Incorrect incubation temperature

Antibody are not enough

Reagent are contaminated

Pipette are not clean

Increasing duration of soaking steps

Incubate at room temperature

Increase the concentration of the antibody

Use new one

Pipette should be clean

No Signal

Reagent are contaminated

Sample prepared incorrectly

Antibody are not enough

Wash buffer contains sodium azide

HRP was not added

Use new one

Make sure the sample workable/dilution

Increase the antibody concentration

Use a new wash buffer and avoid sodium azide in it

Add HRP according to the instruction

Poor Precision

Imprecise/ inaccurate pipetting

Incomplete washing of the wells

 

Check/ calibrate pipettes

Make sure wells are washed adequately by filling the wells with wash buffer and all residual antibody solutions crossed well before washing.

  

 

  

 

 

 

© 2005-2019 Elisa kit,Antibody-Sunlong Biotech Co.,Ltd Copyright, All Rights Reserved.